Download FREE Trial

for use on up to 50 devices for 30 days

By downloading the latest version of NetSupport, you are agreeing to receive periodic mailings and news updates. Should you wish to be removed from this mailing list, please follow the "unsubscribe" directions explained on each of these mailings.


By downloading the latest version of NetSupport, you are agreeing to receive periodic mailings and news updates. Should you wish to be removed from this mailing list, please follow the "unsubscribe" directions explained on each of these mailings.

If you would like our team to assist you with the installation of your free trial or would simply like to schedule a demonstration with a team member either online or in person, then please click here.

System requirements

NetSupport DNA Server component

Minimum hardware: Intel Pentium 4 with 2GB Ram or higher.
Free space required: 300 MB+ (dependent on size of enterprise).
Windows Vista, 7, 8/8.1 and 10. Windows Server 2003 sp2 or higher.

Databases supported: SQL Express (2012 included), SQL Server 2005 or later.
If no version of SQL exists on the target system when installing the DNA Server you will be prompted to either install SQL Express (included in the NetSupport DNA setup file), or to specify the address of an existing SQL Server.

Optional Server modules (SNMP Discovery, Remote Gateways etc).

Windows 7 or higher. Windows Server 2003 sp2 or higher.

NetSupport DNA Management Console

The Console can be installed on multiple machines.
Free space required: 200 MB
Windows 7 or higher. Windows Server 2008 R2 or higher.

DNA Mobile Console apps

Android 4.03 or higher
iOS 7 or higher

DNA Desktop Agent (client)

Free space required: 25 MB
Windows XP sp3 or higher.
Windows Server 2003 sp2 or higher.
Mac OSX 10.8-10.12.

iOS Browser Agent

iOS 7-10.

Chrome Agent

Chrome OS.

Additional "Inventory only" Agents

Linux. (OpenSuSE 13.1 and 13.2, SuSE Enterprise 11 and 12, Ubuntu 12.04, 14.04, 14.10 and 15.04, Edubuntu 12.04 and 14.04, Debian 5, 6, 7 and 8, Red Hat Enterprise Linux 5, 6 and 7, Centos 5, 6 and 7 and Fedora 20, 21 and 22) Mint 17, 17.1 & 17.2
Android 4.x or higher
Windows Mobile 8 or later

Complementary products